package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bfrom \w+ in (\w+)\nprevious in time\b`)
var str = `from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
`
var substitution = "<font color="#FF4500"><b>$0</b></font>"
fmt.Println(re.ReplaceAllString(str, substitution))
}