const regex = new RegExp('\\bfrom \\w+ in (\\w+)\\nprevious in time\\b', 'gm')
const str = `from ab1c_table in WXY
previous in time
from abc3_table in MNO
previous in time
`;
const subst = `<font color="#FF4500"><b>$0</b></font>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);