import re
regex = re.compile(r"\bfrom \w+ in (\w+)\nprevious in time\b", flags=re.MULTILINE)
test_str = ("from ab1c_table in WXY\n"
"previous in time\n\n"
"from abc3_table in MNO\n"
"previous in time\n")
subst = "<font color=\"#FF4500\"><b>$0</b></font>"
result = regex.sub(subst, test_str)
if result:
print(result)