# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[ \t]*\\/\\/.*\r?\n|[ \t]*\\/\\/.*//gm;t' <<< "// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99"