# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*"
test_str = ("// this is awesome code\n"
"const a =1\n\n"
"// this is nice\n"
"const b = 2 // oh great\n\n\n"
" // with some indentation\n"
"const x = 99")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.