const regex = new RegExp('^[ \\t]*\\/\\/.*\\r?\\n|[ \\t]*\\/\\/.*', 'gm')
const str = `// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);