use strict;
my $str = '// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99';
my $regex = qr~^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";