import Foundation
let pattern = #"^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)