using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*";
string substitution = @"";
string input = @"// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}