// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*").unwrap();
let string = "// this is awesome code
const a =1
// this is nice
const b = 2 // oh great
// with some indentation
const x = 99";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}