#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[ \t]*\/\/.*\r?\n|[ \t]*\/\/.*"
Local $sString = "// this is awesome code" & @CRLF & _
"const a =1" & @CRLF & _
"" & @CRLF & _
"// this is nice" & @CRLF & _
"const b = 2 // oh great" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" // with some indentation" & @CRLF & _
"const x = 99"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)