# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\\|\|(.*?)\\\|\|/SPOILER: $1/gm;t' <<< "Hello, I'm your \||spoiler\|| and another one \||spoiler2\||
"