import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\\\|\\|(.*?)\\\\\\|\\|";
final String string = "Hello, I'm your \\||spoiler\\|| and another one \\||spoiler2\\||\n";
final String subst = "SPOILER: $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}