#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\\\|\|(.*?)\\\|\|"
Local $sString = "Hello, I'm your \||spoiler\|| and another one \||spoiler2\||" & @CRLF & _
""
Local $sSubst = "SPOILER: $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)