re = /\\\|\|(.*?)\\\|\|/m
str = 'Hello, I\'m your \\||spoiler\\|| and another one \\||spoiler2\\||
'
subst = 'SPOILER: $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result