package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\\|\|(.*?)\\\|\|`)
var str = `Hello, I'm your \||spoiler\|| and another one \||spoiler2\||
`
var substitution = "SPOILER: $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}