import Foundation
let pattern = #"\\\|\|(.*?)\\\|\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello, I'm your \||spoiler\|| and another one \||spoiler2\||
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"SPOILER: $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)