$re = '/\\\\\|\|(.*?)\\\\\|\|/m';
$str = 'Hello, I\'m your \\||spoiler\\|| and another one \\||spoiler2\\||
';
$subst = "SPOILER: $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;