const regex = /\\\|\|(.*?)\\\|\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\\\|\\|(.*?)\\\\\\|\\|', 'gm')
const str = `Hello, I'm your \\||spoiler\\|| and another one \\||spoiler2\\||
`;
const subst = `SPOILER: $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);