using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\\|\|(.*?)\\\|\|";
string substitution = @"SPOILER: $1";
string input = @"Hello, I'm your \||spoiler\|| and another one \||spoiler2\||
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}