# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:ONE.*)?(ONE.*)/\1/gm;t' <<< "1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST"