import Foundation
let pattern = #"(?:ONE.*)?(ONE.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)