package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:ONE.*)?(ONE.*)`)
var str = `1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}