const regex = /(?:ONE.*)?(ONE.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:ONE.*)?(ONE.*)', 'gm')
const str = `1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);