re = /(?:ONE.*)?(ONE.*)/m
str = '1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result