use strict;
my $str = '1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST';
my $regex = qr/(?:ONE.*)?(ONE.*)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";