import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:ONE.*)?(ONE.*)";
final String string = "1 ONE;TWO;THREE;ONE;FOUR;FIVE\n"
+ "2 ONE;TWO;THREE\n"
+ "3 TEST\n"
+ "4 TEST\n"
+ "5 TEST";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}