// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:ONE.*)?(ONE.*)").unwrap();
let string = "1 ONE;TWO;THREE;ONE;FOUR;FIVE
2 ONE;TWO;THREE
3 TEST
4 TEST
5 TEST";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}