using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$";
string input = @"R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}