import Foundation
let pattern = #"^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)