$re = '/^(R[A-Z]*|U[A-I]|D)([0-9]+)([A-Z]{1,4})$/m';
$str = 'R3KEE
UA3QUP
RK3DSW
U4AI
RU3OZ
RA3QH
RU4I
RL3K
UA3QBQ
UR5EQF
D1IJZ
US3IW
IU3QEU
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);