# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)/$2/g;t' <<< "<span id=\"mensagem\" class=\"topo\">Classes e comandos</span>
<sfdfsdpan id=\"mendsagem\" class=\"topo\">Classes e comandos</span>
<s4856461pan id=\"mensagem\" class=\"topo\">AAAAAA</span>
<span id=\"meaaaaansagem\" class=\"topo\">VOU APRENDER REGEX</span>
<span id=\"mensagem\" class=\"topo\">H1234Ç.,w^</span>
<span id=\"mensagem\" class=\"topo\">VOU APRENDER REGEX</span>
"