using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)";
string substitution = @"$2";
string input = @"<span id=""mensagem"" class=""topo"">Classes e comandos</span>
<sfdfsdpan id=""mendsagem"" class=""topo"">Classes e comandos</span>
<s4856461pan id=""mensagem"" class=""topo"">AAAAAA</span>
<span id=""meaaaaansagem"" class=""topo"">VOU APRENDER REGEX</span>
<span id=""mensagem"" class=""topo"">H1234Ç.,w^</span>
<span id=""mensagem"" class=""topo"">VOU APRENDER REGEX</span>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}