import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)";
final String string = "<span id=\"mensagem\" class=\"topo\">Classes e comandos</span>\n"
+ "<sfdfsdpan id=\"mendsagem\" class=\"topo\">Classes e comandos</span>\n"
+ "<s4856461pan id=\"mensagem\" class=\"topo\">AAAAAA</span>\n"
+ "<span id=\"meaaaaansagem\" class=\"topo\">VOU APRENDER REGEX</span>\n"
+ "<span id=\"mensagem\" class=\"topo\">H1234Ç.,w^</span>\n"
+ "<span id=\"mensagem\" class=\"topo\">VOU APRENDER REGEX</span>\n";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}