#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)"
Local $sString = "<span id="mensagem" class="topo">Classes e comandos</span>" & @CRLF & _
"<sfdfsdpan id="mendsagem" class="topo">Classes e comandos</span>" & @CRLF & _
"<s4856461pan id="mensagem" class="topo">AAAAAA</span>" & @CRLF & _
"<span id="meaaaaansagem" class="topo">VOU APRENDER REGEX</span>" & @CRLF & _
"<span id="mensagem" class="topo">H1234Ç.,w^</span>" & @CRLF & _
"<span id="mensagem" class="topo">VOU APRENDER REGEX</span>" & @CRLF & _
""
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)