# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)"
test_str = ("<span id=\"mensagem\" class=\"topo\">Classes e comandos</span>\n"
"<sfdfsdpan id=\"mendsagem\" class=\"topo\">Classes e comandos</span>\n"
"<s4856461pan id=\"mensagem\" class=\"topo\">AAAAAA</span>\n"
"<span id=\"meaaaaansagem\" class=\"topo\">VOU APRENDER REGEX</span>\n"
"<span id=\"mensagem\" class=\"topo\">H1234Ç.,w^</span>\n"
"<span id=\"mensagem\" class=\"topo\">VOU APRENDER REGEX</span>\n")
subst = "$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.