import Foundation
let pattern = #"(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span id="mensagem" class="topo">Classes e comandos</span>
<sfdfsdpan id="mendsagem" class="topo">Classes e comandos</span>
<s4856461pan id="mensagem" class="topo">AAAAAA</span>
<span id="meaaaaansagem" class="topo">VOU APRENDER REGEX</span>
<span id="mensagem" class="topo">H1234Ç.,w^</span>
<span id="mensagem" class="topo">VOU APRENDER REGEX</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)