use strict;
my $str = '<span id="mensagem" class="topo">Classes e comandos</span>
<sfdfsdpan id="mendsagem" class="topo">Classes e comandos</span>
<s4856461pan id="mensagem" class="topo">AAAAAA</span>
<span id="meaaaaansagem" class="topo">VOU APRENDER REGEX</span>
<span id="mensagem" class="topo">H1234Ç.,w^</span>
<span id="mensagem" class="topo">VOU APRENDER REGEX</span>
';
my $regex = qr/(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";