const regex = /(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)', 'g')
const str = `<span id="mensagem" class="topo">Classes e comandos</span>
<sfdfsdpan id="mendsagem" class="topo">Classes e comandos</span>
<s4856461pan id="mensagem" class="topo">AAAAAA</span>
<span id="meaaaaansagem" class="topo">VOU APRENDER REGEX</span>
<span id="mensagem" class="topo">H1234Ç.,w^</span>
<span id="mensagem" class="topo">VOU APRENDER REGEX</span>
`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);