re = /(<.*?(?=mensagem).*?>)(.*?)(<.*?>)|(.*)/
str = '<span id="mensagem" class="topo">Classes e comandos</span>
<sfdfsdpan id="mendsagem" class="topo">Classes e comandos</span>
<s4856461pan id="mensagem" class="topo">AAAAAA</span>
<span id="meaaaaansagem" class="topo">VOU APRENDER REGEX</span>
<span id="mensagem" class="topo">H1234Ç.,w^</span>
<span id="mensagem" class="topo">VOU APRENDER REGEX</span>
'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result