# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n[ \t]+for / | /gm;t' <<< "T=\"topic 1\"
for xxx@xxx.com
T=\"topic 2\"
for yyy@yyy.com"