re = /\n[ \t]+for /m
str = 'T="topic 1"
for xxx@xxx.com
T="topic 2"
for yyy@yyy.com'
subst = ' | '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result