using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n[ \t]+for ";
string substitution = @" | ";
string input = @"T=""topic 1""
for xxx@xxx.com
T=""topic 2""
for yyy@yyy.com";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}