import Foundation
let pattern = #"\n[ \t]+for "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
T="topic 1"
for xxx@xxx.com
T="topic 2"
for yyy@yyy.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" | "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)