// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\n[ \t]+for ").unwrap();
let string = "T=\"topic 1\"
for xxx@xxx.com
T=\"topic 2\"
for yyy@yyy.com";
let substitution = " | ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}