package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n[ \t]+for `)
var str = `T="topic 1"
for xxx@xxx.com
T="topic 2"
for yyy@yyy.com`
var substitution = " | "
fmt.Println(re.ReplaceAllString(str, substitution))
}