#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\n[ \t]+for "
Local $sString = "T="topic 1"" & @CRLF & _
" for xxx@xxx.com" & @CRLF & _
"T="topic 2"" & @CRLF & _
" for yyy@yyy.com"
Local $sSubst = " | "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)