import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n[ \\t]+for ";
final String string = "T=\"topic 1\"\n"
+ " for xxx@xxx.com\n"
+ "T=\"topic 2\"\n"
+ " for yyy@yyy.com";
final String subst = " | ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}