# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w{7})\w+/\1/gm;t' <<< "I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing."