package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\w{7})\w+`)
var str = `I am doing text processing using CountVectorizer/logistic regression and comparing f1 score for no preprocessing vs preprocessing.`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}